Intermitted reporting issue on My Surveys Tab

Incident Report for Prevalent

Resolved

This issue now been resolved
Posted May 11, 2026 - 13:05 UTC

Monitoring

A fix has been implemented and we are actively monitoring the results.
Posted May 11, 2026 - 12:11 UTC

Identified

We have identified an issue on the My Surveys tab and are actively working on resolving this issue.
Posted May 07, 2026 - 13:42 UTC